segunda-feira, 29 de agosto de 2011

Instalação da Suite Aircrack no Slackware v13.37 64b

Palavras-chave: Aircrack, Aircrack no Slackware, Instalação do Aircrack, Erro canal -1.

Para instalar a Suite Aircrack precisamos dos seguintes pacotes:

aircrack-ng-1.1-x86_64-1sl
glibc-solibs >= 2.11.1-x86_64-3
openssl >= 0.9.8n-x86_64-1 | openssl-solibs >= 0.9.8n-x86_64-1
sqlite >= 3.6.23.1-x86_64-1

PROCEDIMENTO

Inicialmente vamos abrir o Konsole e criar um diretório chamado Aircrack.

$ su
$ senha de root
# mkdir /opt/Aircrack
# cd /opt/Aircrack

Agora iremos fazer o download da Suite Aircrack e dos pacotes (bibliotecas C e Security Sockets) necessários.

aircrack-ng

# wget http://repository.slacky.eu/slackware64-13.1/security/aircrack-ng/1.1/aircrack-ng-1.1-x86_64-1sl.txz

glibc-solibs

# wget http://slackware.cs.utah.edu/pub/slackware/slackware64-13.37/slackware64/a/glibc-solibs-2.13-x86_64-4.txz

openssl | openssl-solibs

# wget http://slackware.cs.utah.edu/pub/slackware/slackware64-13.37/slackware64/n/openssl-0.9.8r-x86_64-3.txz

sqlite

# wget http://slackware.cs.utah.edu/pub/slackware/slackware64-13.37/slackware64/ap/sqlite-3.7.5-x86_64-1.txz

Após o download, instale os pacotes da seguinte forma:

# installpkg aircrack-ng-1.1-x86_64-1sl.txz
# installpkg glibc-solibs-2.13-x86_64-4.txz
# installpkg openssl-0.9.8r-x86_64-3.txz
# installpkg sqlite-3.7.5-x86_64-1.txz

TESTES

Os testes podem ser realizados com base no guia para iniciantes. 

ERRO DE CANAL -1

Para solucionar este problema que trava a interface de rede no canal -1, deve-se instalar um driver (compat-wireless) e um patch de correção. Os procedimentos abaixo são válidos para as seguintes versões de kernel e driver:

Kernel v.2.6.24 ou mais recente.
Compat-wireless v.3.3-rc1-2 ou superior. 

No meu caso as versões são:

Kernel v.2.6.37.6 e Compat-wireless v.3.6-rc7-1. 

Para verificar a versão do kernel:

$ uname -ar 

Acesse o diretório do Aircrack (criado no inicio):

$ cd /opt/Aircrack

Baixe a versão mais recente do compat-wireless no site Wireless Kernel (link abaixo) e descompacte o arquivo.

$ tar  -xvjf compat-wireless-3.6-rc7-1.tar.bz2
$ cd compat-wireless-3.6-rc7-1

Faça o download do patch.

$ wget http://patches.aircrack-ng.org/mac80211.compat08082009.w1_frag+ack_v1.patch

Ao término do download digite:

$ patch -p1 <  mac80211.compat08082009.w1_frag+ack_v1.patch

Se não aparecer nenhuma mensagem de erro no comando acima, selecione seu driver:

$ ./scripts/driver-select

No meu caso, utilizo uma interface de rede wireless da Intel.

$ ./scripts/driver-select intel
$ make
$ sudo make install
$ sudo make wlunload
$ sudo modprobe iwlwifi

Quando a instalação estiver concluída reinicie o computador.

Para versões anteriores de kernel e driver, deve-se ler a documentação Compat-Wireless (link abaixo) disponível no site do Aircrack.

Materiais/Links relacionados



Nenhum comentário: